seeing if it's easier to fork tA's nixos laptop config rather than make one from scratch (more or less).
Nie możesz wybrać więcej, niż 25 tematów Tematy muszą się zaczynać od litery lub cyfry, mogą zawierać myślniki ('-') i mogą mieć do 35 znaków.

45 wiersze
846B

  1. { pkgs, config, ... }:
  2. {
  3. imports = [
  4. ./drives.nix
  5. ./keyboard.nix
  6. ./network.nix
  7. ./wireless.nix
  8. ./power.nix
  9. ./opengl.nix
  10. ./sound.nix
  11. ];
  12. environment.systemPackages = with pkgs; [
  13. acpi
  14. ];
  15. console.keyMap = "dvorak";
  16. hardware.bluetooth.enable = false;
  17. hardware.opengl.driSupport32Bit = true;
  18. system.stateVersion = "20.09";
  19. boot.supportedFilesystems = [ "ntfs" ];
  20. boot = {
  21. loader = {
  22. systemd-boot.enable = true;
  23. efi.canTouchEfiVariables = true;
  24. };
  25. initrd = {
  26. availableKernelModules = [
  27. "ehci_pci" "ata_piix" "usbhid"
  28. "usb_storage" "sd_mod" "sdhci_pci"
  29. ];
  30. kernelModules = [ "dm-snapshot" "i915" ];
  31. };
  32. kernelModules = [ "kvm-intel" "acpi_call" ];
  33. extraModulePackages = with config.boot.kernelPackages; [ acpi_call ];
  34. };
  35. }