seeing if it's easier to fork tA's nixos laptop config rather than make one from scratch (more or less).
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

28 lines
725B

  1. { pkgs, ... }:
  2. {
  3. # to do: make this parameterised
  4. services.actkbd = {
  5. enable = true;
  6. bindings = [
  7. { keys = [ 113 ];
  8. events = [ "key" ];
  9. command =
  10. "/run/current-system/sw/bin/runuser -l thorn -c '${pkgs.alsaUtils}/bin/amixer -q set Master toggle'";
  11. }
  12. { keys = [ 114 ];
  13. events = [ "key" "rep" ];
  14. command =
  15. "/run/current-system/sw/bin/runuser -l thorn -c '${pkgs.alsaUtils}/bin/amixer -q -c 0 set Master 4- unmute'";
  16. }
  17. { keys = [ 115 ];
  18. events = [ "key" "rep" ];
  19. command =
  20. "/run/current-system/sw/bin/runuser -l thorn -c '${pkgs.alsaUtils}/bin/amixer -q -c 0 set Master 4+ unmute'";
  21. }
  22. ];
  23. };
  24. }