my laptops nixos configuration, hopefully less messy this time (but still a lil' messy)
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

26 lines
342B

  1. { pkgs, ... }:
  2. {
  3. networking = {
  4. networkmanager.enable = false;
  5. wireless = {
  6. enable = true;
  7. interfaces = [
  8. "wlp3s0"
  9. ];
  10. };
  11. };
  12. environment.systemPackages = with pkgs; [
  13. wirelesstools
  14. ];
  15. hardware.enableRedistributableFirmware = true;
  16. boot = {
  17. kernelModules = [ "cfg80211" ];
  18. };
  19. }