You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

18 lines
487B

  1. {
  2. description = "ghc with plugins for aoc";
  3. inputs = {
  4. nixpkgs.url = "github:NixOS/nixpkgs/nixos-20.09";
  5. flake-utils.url = "github:numtide/flake-utils";
  6. };
  7. outputs = { self, nixpkgs, flake-utils, ... }:
  8. flake-utils.lib.eachDefaultSystem
  9. (system:
  10. let pkgs = nixpkgs.legacyPackages.${system}; in
  11. {
  12. defaultPackage = pkgs.haskellPackages.ghcWithPackages
  13. (hpkgs: with hpkgs; [
  14. vector
  15. ]);
  16. });
  17. }