a one dimensional cellular automata, using comonads
Nie możesz wybrać więcej, niż 25 tematów Tematy muszą się zaczynać od litery lub cyfry, mogą zawierać myślniki ('-') i mogą mieć do 35 znaków.

20 wiersze
515B

  1. {
  2. description = "a basic cellular automata using comonads";
  3. inputs = {
  4. nixpkgs.url = "github:NixOS/nixpkgs/nixos-20.09";
  5. flake-utils.url = "github:numtide/flake-utils";
  6. };
  7. outputs = { self, nixpkgs, flake-utils, ... }:
  8. flake-utils.lib.eachDefaultSystem (system:
  9. let
  10. pkgs = import nixpkgs {
  11. overlays = [ (import ./overlay.nix) ];
  12. inherit system;
  13. };
  14. in {
  15. defaultPackage = pkgs.cellularAutomata;
  16. }) // {
  17. overlay = import ./overlay.nix;
  18. };
  19. }