a one dimensional cellular automata, using comonads
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

18 lines
491B

  1. { mkDerivation, base, brick, containers, deepseq, lib, linear
  2. , microlens, microlens-th, ncurses, process, random, turtle, vty
  3. }:
  4. mkDerivation {
  5. pname = "cellularAutomata";
  6. version = "0.1.0.0";
  7. src = ./..;
  8. isLibrary = false;
  9. isExecutable = true;
  10. executableHaskellDepends = [
  11. base brick containers deepseq linear microlens microlens-th process
  12. random turtle vty
  13. ];
  14. executableSystemDepends = [ ncurses ];
  15. license = "unknown";
  16. hydraPlatforms = lib.platforms.none;
  17. }