emacs nix flake
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

24 lines
516B

  1. {
  2. description = "tA's emacs setup";
  3. inputs = {
  4. nixpkgs = {
  5. url = "github:NixOS/nixpkgs/nixos-20.09";
  6. };
  7. flake-utils = {
  8. url = "github:numtide/flake-utils";
  9. };
  10. };
  11. outputs = { self, nixpkgs, flake-utils, ... }:
  12. flake-utils.lib.eachDefaultSystem (system:
  13. let
  14. pkgs = import nixpkgs {
  15. overlays = [ (import ./overlay.nix) ];
  16. inherit system;
  17. };
  18. in {
  19. defaultPackage = pkgs.ta.emacs;
  20. }) // {
  21. overlay = import ./overlay.nix;
  22. };
  23. }