You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

23 lines
582B

  1. {
  2. description = "a nix flake for compiling julia programs";
  3. inputs = {
  4. nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable";
  5. flake-utils.url = "github:numtide/flake-utils";
  6. };
  7. outputs = { self, nixpkgs, flake-utils, ... }:
  8. flake-utils.lib.eachDefaultSystem (system:
  9. let pkgs = nixpkgs.legacyPackages.${system};
  10. in rec {
  11. packages = {
  12. juliaSkele = (import ./juliaDeri.nix) {
  13. pkgs = pkgs;
  14. pname = "myjulia";
  15. mainFile = "src/PlotTest.jl";
  16. };
  17. };
  18. defaultPackage = packages.juliaSkele;
  19. }
  20. );
  21. }