my vim setup, as a nix flake
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

62 lines
1.3KB

  1. customPlugins: self: super: {
  2. ta = {
  3. vim = super.vim_configurable.customize {
  4. name = "vim";
  5. vimrcConfig = {
  6. pathogen = {
  7. knownPlugins = super.vimPlugins // (customPlugins super);
  8. pluginNames = [
  9. "rainbow-vim"
  10. "vimwiki"
  11. "slimv"
  12. "vim-racket"
  13. ];
  14. };
  15. customRC = ''
  16. set nocompatible
  17. filetype on
  18. filetype plugin on
  19. filetype indent on
  20. syntax on
  21. colorscheme delek
  22. if has("autocmd")
  23. au BufReadPost *.rkt,*.rktl set filetype=racket
  24. au filetype racket set lisp
  25. au filetype racket set autoindent
  26. endif
  27. set encoding=utf-8
  28. set autoindent
  29. set smartindent
  30. set ignorecase
  31. set smartcase
  32. set hlsearch
  33. set history=100
  34. set number
  35. set wildmenu
  36. set backspace=eol,indent,start
  37. set tabstop=2 softtabstop=2 expandtab shiftwidth=2 smarttab
  38. let g:rainbow_active = 1
  39. imap <C-L> λ
  40. let g:rainbow_conf = {
  41. \ 'ctermfgs': ['red', 'green', 'blue', 'cyan', 'magenta'],
  42. \ 'cterms': ['bold']
  43. \}
  44. '';
  45. };
  46. };
  47. };
  48. }